Incubator, Laboratory Forums

0 Replies

Dear Wizards, My Innova Incubator is stuck on 27 degrees. We mostly use the 37 degree temperature. Does anyone know how to reprogram ? Very many thanks, Beily

RE: EPPENDORF - New Brunswick Innova 43/43R
Added  Sep 29 2021
0 Replies

Hi, I'm looking for the service manual of Jouan IG 650 thanks

RE: Thermo Scientific - Jouan IG 650
Updated  Sep 23 2021
2 Replies

Hi, did someone have the service manual of the incubator IG 650 of the Lab? My equipement has a CO2 at 6.5 CO2, I have try to put at 5 % but it doest stay. so think that I have to calibrate , so i need the manual if someone has. thanks

RE: Thermo Scientific - Jouan IG 650
2 Replies

Once heater reaches set temp value, after 10-15 min the temp display value drops to apx 10 degrees. Did temp calibration as per manual. How to fix it. Can someone post a troubleshooting tips ? and please provide service manual if anybody has . Thanks

RE: Techne - DB100/3
Updated  Jan 27 2021
2 Replies

I cannot find any info anywhere on how to calibrate the temperature in this incubator. According to my thermometer it is off by 1 deg. C @37 deg. C. Could you help me with this? Thanks, Joe

RE: Infors HT - Minitron
Added  Dec 2 2020
0 Replies

Does anyone know how to open / repair a stuck door on an Innova 44?

RE: EPPENDORF - New Brunswick™ Innova® 44/44R
0 Replies

Anyone out there with experience repairing these units? We have one that is not powering on.

RE: EPPENDORF - New Brunswick™ Innova® 44/44R
Updated  Mar 28 2018
1 Reply

Hello, LCD display brightness is low, is there any function can increases brightness?

RE: EPPENDORF - New Brunswick™ Innova® 44/44R
Updated  Mar 29 2017
2 Replies

This question is about a LabNet Vortemp 56 Temperature Chamber Shaker. I am getting an Error 5 (Err5) after 3 seconds from a Start. The User manual states that this error usually appear when the user open the lid while the unit is running, making a temperature distortion, hence the operation error 5. None of that is the actual case. The error appear just after starting a session. The lid stay close. I suspected the Lid Switch or a sensor broken. It is not the case. If anyone happen to have a service manual for this apparatus it would be greatly appreciated if you could upload it. Cheers

Updated  Apr 3 2017
3 Replies

This question is about a LabNet Vortemp56 Temperature Chamber Shaker. I am getting an Error 5 (Err5) after 3 seconds from a Start. The User manual states that this error usually appear when the user open the lid while the unit is running, making a temperature distortion, hence the operation error 5. None of that is the actual case. The error appear just after starting a session. The lid stay close. I suspected the Lid Switch or a sensor broken. It is not the case. If anyone happen to have a service manual for this apparatus it would be greatly appreciated if you could upload it. Cheers

Ask a Question

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree