GE Healthcare OEC 9900 Elite Forums

Updated  May 19 2021
4 Replies

GE Healthcare - OEC 9900 Elite
Can anyone explain how to operate the 9900 Elite C-arm for vascular use? Or is there a user guide/operator manual available somewhere? GE doesn't appear to want to share the information to the general public. I guess they want people to pay for an entire course. I know to go to "Mode-Subtraction" or something similar, but would like more clear instructions. I'd appreciate any information or links - thanks so much in advance. Debbie

RE: GE Healthcare - OEC 9900 Elite
Added  Dec 3 2020
0 Replies

GE Healthcare - OEC 9900 Elite
I need some info on the WISP module on the 9900 Elite C-Arm. Could you please if available send me the service manual concerning the WISP. Thanks

RE: GE Healthcare - OEC 9900 Elite
5 Replies

GE Healthcare - OEC 9900 Elite
Is there an internal setting that needs to be set for the DVI output to provide a live video signal? when I connected that was no live signal from the system.

RE: GE Healthcare - OEC 9900 Elite
Added  Oct 29 2020
0 Replies

GE Healthcare - OEC 9900 Elite
Poor resolution using normal mode, mag 1 and mag 2 perfect resolution. Has anyone experienced this problem before?

RE: GE Healthcare - OEC 9900 Elite
Added  Oct 29 2020
0 Replies

GE Healthcare - OEC 9900 Elite
No power to WiSP upon powering up the C-Arm. Do we have a dead powerpack?

RE: GE Healthcare - OEC 9900 Elite
Updated  Aug 27 2020
4 Replies

GE Healthcare - OEC 9900 Elite
Hi guys, I am getting an error on the 2nd monitor screen which reads as follows: Initializing......ERROR! Adaptor Malfunctioning! SMPT BIOS Fault 13h encountered at adaptor PCI(03h,05h,00h) Press any key to continue.... So what we did is to connect a PS/ 2 keyboard to the board and was able get in. We've replaced the CPU board but did not fix it. We're looking for a permanent fix and would appreciate any suggestion how to solve this problem. Thank you,

RE: GE Healthcare - OEC 9900 Elite
Updated  Jul 26 2020
2 Replies

GE Healthcare - OEC 9900 Elite

Hi, guys. I have a OEC 9900 Elite system that doesn't boot up. The C-arm gets stuck after 11 arrows, and the left monitor shows this error message: "SYSTEM ERROR DETECTED X-rays are disabled. Turn the system off, wait 10 seconds, and then restart the system. If this message persists, call for service. Service Information: Vortex IP board is not detected!" I cannot connect with the system using UtilitySuite. When monitoring the booting process with Display Adapter's switch in service mode, it seems that the system tries to erase the flash nodes and reload them, but it fails showing the message "Board firmware validation FAILED!". I reloaded software but the issue continues. All voltages seem to be OK in the passive backplane. I cleaned and reseated all the boards and cables in the rack, visually inspected the Vortex IP board and it seems OK. It does not turn on any LED after booting. I think it could be a defective Vortex IP board but I want to be sure. What else should I check?

RE: GE Healthcare - OEC 9900 Elite
Updated  Apr 14 2020
6 Replies

GE Healthcare - OEC 9900 Elite
Hello, Does anyone have the service manuals for the new GE OEC Elite?

RE: GE Healthcare - OEC 9900 Elite
Updated  Mar 27 2020
1 Reply

GE Healthcare - OEC 9900 Elite
Restarting doesn't help. Can anyone help? Thanks.

RE: GE Healthcare - OEC 9900 Elite
Updated  Feb 18 2020
1 Reply

GE Healthcare - OEC 9900 Elite
Does the 9900 elite need to be changed off-line when not in use? If so how frequently and for how long? Does the arm need to be attached to the monitor unit during charging?

RE: GE Healthcare - OEC 9900 Elite

Start a Thread

Equipment Name: GE Healthcare - OEC 9900 Elite
SIGN IN FIRST
This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree