Mon Aug 25 2014

Heraeus Multifige kepts tripping out

Hello

We have a problem with our Multifuge losing power.  There is switch inside the unit that we need to reset to get the unit powered back on.  Company techs believe that our power supply is the problem but to me this seems unlikely.  Anyone has any advice

Many thanks

 


Report Post
Mon Aug 25 2014Reply from chris?
avatar placemark

Try a different outlet or circuit in the office to see what happens


Report Post
Thu Mar 05 2015Reply from Mal1
avatar placemark

I been having the same problem, the service technicians replace the RESET switch and the unit it sites on not the power supply. This didn't fix the problem we have been living with as they couldn't locate what was causing it to over heat. We have been resetting about once a month but this week its started to trip overnight and now soon after resetting. The unit overheats with the lid up and the cooling not running. Where you able to get yours fixed?


Report Post
Thu Mar 05 2015Reply from LRF
avatar placemark

Hello,

Bear in mind that the electric outlet bank may be sharing the current with other high energy usage devices (aka centrifuges, refrigerators, cryostats, etc)  especially devices that intermittently draw power (aka refrigerators) will create this periodic issue.  Review your electronics training on apparent power and inrush currents.

Additionally, the size of the wire (in the wall) supplying the circuit can be a culprit.  Loose outlet screws bonding the wire in the outletetc...  I have seen similar isses that were traced back to poor electrical work.  Do not asume they did what was written on the blueprint.  I had one facilty that detroyed a single phase laser due to poor wiring;  a $100,000 "mistake".

Let me know what you find.


Report Post

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree