Advertisement
Home > Q&A > Need to solve the problem
Advertisement
Fri Aug 04 2017

Need to solve the problem

The problem is the unit ready symbol does not appear after pressing the button. Assuming the button already check and ok no fuse blown in the control system.
Report Post
Wed Aug 09 2017Reply from SHAH SHAH
avatar placemark

Dear brother call me on Whatsapp number 

+923214396482

If u can 

 


Report Post
Wed Aug 09 2017Reply from SHAH SHAH
avatar placemark

Dear brother call me on Whatsapp number 

+923214396482

If u can 

 


Report Post
Wed Aug 09 2017Reply from Larry Pines
avatar placemark

I check the contactor its ok. I check with Volt ohm meter tester.  I check the button switch its still ok. I check the x ray head the rotor not working 


Try and try until you succeed.
Report Post
Tue Aug 08 2017Reply from SHAH SHAH
avatar placemark

Dear brother check the status of ready contactor when you press ready switch 

ON or OFF


Report Post
Mon Aug 07 2017Reply from Larry Pines
avatar placemark

Toshiba chest x ray model KXO 15 r/z1

 

Problem : No prepartion or ready no exposure. Rotor not working in x ray head


Try and try until you succeed.
Report Post
Mon Aug 07 2017Reply from MedWrench MM
Larry Pines

What equipment (make and model) are you specifically referring to?


Jonathan F. Payne,
Media Manager @ MedWrench,
866-989-7057,
Jpayne@MedWrench.com
Report Post

For questions about using the MedWrench web site:

(866) 989-7057TOLL FREE  •  (770) 692-8371INTERNATIONAL

support@medwrench.com

MedWrench is in association with:

TechNationMedical DealerOR TodayMD Expo


Testimonials  •  Advertising  •  Privacy Policy  •  Terms and Conditions

© 2017 MedWrench, LLC. All Rights Reserved