Wed Mar 07 2018

Collimator/Iris/Filament cal. error

Hello, I have an OEC 9900 that when booted up I get 3 messages on the C-arm. Collimator cal. error, Iris cal. error, and Filament cal. error. I can ok out of messages by hitting any button and can produce images. I did notice that my collimator iris buttons are reversed. I dont have documentation for this unit. I do however have RUT software and unable to connect with serial. I connected with crossover cable and could connect but nothing populates for generator. If i try to run calibrations I get an error message. Any suggestions would be appreciated. Thanks

Report Post
Thu Mar 08 2018Reply from oldxrayguy
avatar placemark

The two thing these three sub-systems have in common is the cable from the c-arm base to the tub/collimator and the CCD TV camera head; and the hard drive.

You can get the service manual Supplement from the GE website. It's only 3.9MB.  Send me an email and I can get that and some other stuff to you.  glee@jannx.com

The supplement manual recommends re-loading or creating new cal files.  Strange that all three are acting up. 


Report Post
Thu Mar 08 2018Reply from Rad Rays LLC
avatar placemark

It sounds like the Generator has lost all of it's cal files. This could be caused by a dead battery on the GIB or a defective GIB altogether. Please call us at Rad Rays Llc for some free tech support 410-737-4404.


Report Post
Fri Mar 09 2018Reply from BMET-KY
avatar placemark

I was able to solve my issue. First was trying to connect to archnet with a serial. I was never able to get that to work but was able to using a crossover Cat5 cable. The next problem was my coin battery on the Gen. Interface board was low and wiped out my calibration data. I wasn’t able to load generator settings form the system to rerun cals. After connecting to system I tried running cals with out loading system settings and could run them however it defaulted all other settings and wouldn't allow me to boot back in it asked for a password. Luckily I found a backup disk and was able to restore the generator and then run new cals.


Report Post

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree