Fri Jul 13 2018

Ziehm 7000 has only zeros on the panel

The Ziehm 7000 unit was in a building that had a power outage. When the unit was brought back up all the lights are zeros. The arm can still be moved by the panel up and down. I get no error codes. Does anyone have an idea or a schematic diagram or service manual?
Report Post
Mon Jul 16 2018Reply from Kennedy Krieg
avatar placemark

MedWrench is available to help people with specific questions and troubleshooting problems. Could you please be more specific with the issue that you are having with your instrument?

The MedWrench team will do their best to assist you in solving the issue. This will also help other community members who face similar challenges.


Kennedy Krieg
MedWrench - Digital Marketing Executive
email us: info@medwrench.com
Report Post
Mon Jul 16 2018Reply from ceshop
avatar placemark

i can send you the service manuals


Report Post
Mon Jul 16 2018Reply from Alex Wright
ChristieBecker

Hello, if you have manuals you would like to share for this item you can email them to me and we will post them. Thank you


Alexandra Wright
MedWrench - Sales & Marketing Coordinator
email me: awright@medwrench.com
Report Post
Mon Jul 16 2018Reply from Alex Wright
ChristieBecker

Documents have been uploaded thanks to user ceshop


Alexandra Wright
MedWrench - Sales & Marketing Coordinator
email me: awright@medwrench.com
Report Post
Mon Jul 16 2018Reply from ChristieBecker
avatar placemark

Thank you for the service manuals.


Report Post
Sun Jul 22 2018Reply from ChristieBecker
avatar placemark

For anyone who has this issue, found a red error light on the U325 board, but found it was reslly just the keyboard on the C-arm base.  Takes a little time to replace, but simple to work on.


Report Post

Ziehm Imaging - 7000
by Ziehm Imaging

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree