Fri Feb 19 2021

ALARM too long in charge

Has anyone got any good ideas for this alarm? Not passing Dart test .

Report Post
Fri Feb 19 2021Reply from Ben C
Ben C

What is the name of the manufacturer and model of the equipment you are working on? 


Find me on FacebookLinkedIn, YouTube or Twitter 
 

Report Post
Fri Feb 19 2021Reply from LELA
avatar placemark

STERIS AMSCO CENTURY V116


Report Post
Fri Feb 19 2021Reply from Bob@montaquip
avatar placemark

Turn pressure regulator screw one full revolution clockwise to increase pressure.
 

This answer is based only on limited info you've provided. It's not hitting set point (272-274f) soon enough causing alarm. 


Report Post
Fri Feb 19 2021Reply from Bob@montaquip
avatar placemark

Sorry, you might want to check to see there's nothing clogging the removable screen in bottom of chamber first 


Report Post
Fri Feb 19 2021Reply from Chris35
avatar placemark

As Bob said, more info would really help. Can you provide the info printed below the ALARM line? Pressure / Temp.. As well as what part of the cycle you get the alarm.

Just being that alarm we know you have some steam pressure because the door is sealed. If it is in the first pressure phase of condition, it is probably S2. It has to reach 26 PSIG before the set time limit. If it is in the Charge phase after the pre-vac pulses, it could be the PRV, S3, TR1, or debris in the chamber strainer. It has to reach set sterilize temp before the set time limit.


Report Post
Fri Feb 19 2021Reply from LELA
avatar placemark

DART TEST 

TOO LONG IN CHARGE

F  7:44:32A   260.3    21P

* ABORT        7:44:40A

D  7:44:57A   208.3      8.OV


Report Post
Fri Feb 19 2021Reply from LELA
avatar placemark

I ALSO STARTED A LEAK TEST 

C   1:28:23P    178.3     0.2P

C    1:29:24P    239.6     0.8P

C     1:30:26P    221.0    19.4P

*ALARM    TOO LONG IN CHARGE

F      1:50:27P   260.7    21P

 


Report Post
Fri Feb 19 2021Reply from Bob@montaquip
avatar placemark

Did you accidentally open the ball valve on top left front above chamber just behind front door? It should be at a 90degree angle. Your only achieving 21 psi which means there's probably a leak. S3 drain valve blown or perhaps chamber trap not closing. Only other thing is manual valve mentioned above.

 


Report Post
Mon Feb 22 2021Reply from Chris35
avatar placemark

Verify pressure with an accurate reference. 260* at 21psi seems high. Also, 0.8psi after the purge is screaming bad S2 valve to me, but Bob's right, you are either losing pressure too fast (S3, emerg exhaust, trap) or you're not getting enough to the chamber. (S2, PRV, steam strainer) I find it's more of a "how's it sound" technique, do you hear a big rush of steam when S2 opens? Does it start strong then trickle out? Does the trickle start when the jacket pressure equalizes with the chamber? (PRV) Verify PRV by opening S9 in service mode and make sure the jacket charges to ~40-45 psi. How old are the steam manifold valves? These are 1 year parts and past that is a craps shoot.


Report Post
Mon Feb 22 2021Reply from Cbet_Matt
Cbet_Matt

Does your boiler go below 40 psi during charge cycle? Does it recover quickly after a purge or does it go below 40 psi?



Matt

 
Report Post

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree