Wed Mar 09 2022

Hydrolic manifold

I have an issue where my sub assembly won't extend and the motor just over drives itself, it will collapse when given the comand to but just wont extend or stay extended with the manual release closed. originally i had suspected i was low on fluid as this was a repair based on a massive leak with the reservoir cover. part of me is suspecting it may be the A or B valve but its hard to say.

   RE: Stretcher Report Post
Tue Mar 15 2022Reply from MedWrench Manager
MedWrench Manager

Agiliti may be able to assist with this issue.


Report Post
Tue Mar 15 2022Reply from Ray Brown, CBET
avatar placemark

From the best guess on which version you have (there are 2 different models and several serial number variations)

Base/litter does not extend in the powered mode.

Check battery indicator light. 1.

A. If blinking constant RED, change battery.

B. If blinking a patterned RED flash short, long, long:

i. Check for broken or disconnected wires.

ii. Check for 24 VDC at connector (B) on the main cable by the motor while pressing the (+) button. If voltage is present, replace (in order) the hall effect sensor, solenoid, and or ‘A’ valve. If voltage is not present, go to step iii.

iii. Check for 24 VDC on electronics assembly pins 2 white and 6 red on (F) while pressing the (+) button. If voltage is not present, replace the electronics assembly. If voltage is present, replace the wire harness.

C. If the GREEN light turns on, but does not lower, try the other switch. If the other switch works, replace the bad switch.

Check motor. 2.

A. If the motor runs, but does not raise the cot:

i. Check the manual release cable for too much tension.

ii. Lightly tap the manual locking valve.

iii. Replace the manual locking valve.

B. If the motor is stalled, replace the ‘A’ valve.

C. If the light is GREEN, but the motor does not run

i. Check for 24 VDC at connector (E) on the main cable. If voltage is present, replace the hall effect sensor. If the hall effect sensor is replaced, and the motor still does not run, replace the hydraulic sub assembly. If voltage is not present, go to step ii.

ii. Check for 24 VDC on electronics assembly connection (H) (-) lead on black (+) lead on green while pressing the (+) button. If voltage is not present, replace the electronics assembly. If voltage is present, replace the main cable.


Report Post

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree