Tue Jun 20 2023

Alaris 8015 PC not turning on

Whenever I press the System On key, the red arrow starts blinking and the unit beeps until i press the System on key again. I've tried holding the tamper to go into maintenance mode and that doesn't work either. 

It has a battery from this year. I charged it overnight and the issue continues this morning. Not sure if others have ran into this or what else to try. 

   RE: Infusion Pump Report Post
Tue Jun 20 2023Reply from rsiefers
avatar placemark

the switching supply is bad (inside under handle)

replace it and do a battery condition. Problem should then be gone. However check to see if your unit is charging-I've had a bad power cord cause this type of problem too

Report Post
Wed Jun 21 2023Reply from SeanRenovo
avatar placemark

Tried new power cord, still happened. Waiting on the part now and i'll update! Thank you!

Report Post
Wed Jul 05 2023Reply from SeanRenovo
avatar placemark

Swapped out a new switching supply but no dice! Ended up sending it out for service. 

Report Post

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree