Wed Apr 03 2024

Unit does not reach the operating pressure

What should be the problem

Equipment: Tuttnauer3870M


   RE: Sterilizers/Autoclaves Report Post
Wed Apr 03 2024Reply from Emily Vitkovitsky
Emily Vitkovitsky

If you are in need of immediate assistance please feel free to reach out directly to our sponsors. They are happy to help.

MERCO Biomedical

 

Just be sure to tell them you were referred by MedWrench     


Report Post
Thu Apr 04 2024Reply from MapleTreeBiomed
MapleTreeBiomed

Hi Eosias_4725,

There are a few reasons why the unit isn't building pressure. Either there is a steam leak or the unit isn't getting hot enough. Typically it's a leak. Open up the water fill port on the top of the machine and observe it during the cycle. There should be a small leak coming from the air jet. That's a small hole on the side of the safety valve with a wire loop sticking out of it. The over pressure safety valve may be worn out and could start leaking.  If water is draining through the condensing coil during the cycle then the multi-function valve may be bad. Is the door gasket cracked and letting steam escape? The service manual can be found in the documents section and that has some more suggestions.

Good Luck!


Report Post
Thu Apr 04 2024Reply from T-Lobato
T-Lobato

Have you looked at the service manual located under "Documents" on the left side of the page?  It has a good troubleshooting guide.

T.


TJ Lobato | MedWrench Guru
Report Post

This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies. Please review our Privacy Policy for more details.
I Agree